vendor:
Wireshark
by:
sinn3r
7.5
CVSS
HIGH
Remote Code Execution
78
CWE
Product Name: Wireshark
Affected Version From: 1.6.2000
Affected Version To: 1.6.2001
Patch Exists: YES
Related CWE: CVE-2011-3360
CPE: a:wireshark:wireshark
Other Scripts:
https://www.infosecmatter.com/nessus-plugin-library/?id=57263, https://www.infosecmatter.com/nessus-plugin-library/?id=76045, https://www.infosecmatter.com/nessus-plugin-library/?id=61928, https://www.infosecmatter.com/nessus-plugin-library/?id=56164, https://www.infosecmatter.com/nessus-plugin-library/?id=56163, https://www.infosecmatter.com/metasploit-module-library/?mm=exploit/windows/misc/wireshark_lua, https://www.infosecmatter.com/list-of-metasploit-windows-exploits-detailed-spreadsheet/
Tags: N/A
CVSS Metrics: N/A
Nuclei References:
N/A
Nuclei Metadata: N/A
Platforms Tested: Windows
2011
Wireshark console.lua pre-loading vulnerability
This modules exploits a vulnerability in Wireshark 1.6 or less. When opening a pcap file, Wireshark will actually check if there's a 'console.lua' file in the same directory, and then parse/execute the script if found. Versions affected by this vulnerability: 1.6.0 to 1.6.1, 1.4.0 to 1.4.8.
Mitigation:
Upgrade to Wireshark 1.6.2 or later.